`

poj 1258 Agri-Net-----最小生成树 prim

 
阅读更多

Agri-Net
Time Limit:1000MS Memory Limit:10000K
Total Submissions:26418 Accepted:10425

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28


题目大意: 将 已知 距离的 一些点 连接起来, 总的 距离最少。

思路: 以一个点为 起始, 每次找下一个 最短 边,直到找到最小生成树。

//Memory: 208 KB		Time: 16 MS
//Language: C++		Result: Accepted

#include<stdio.h>
#include<string.h>
const int MAX=1000050;
int dis[105][105],n,vir[105],t[105],sum;
void minDis(int n);
int main()
{
	//freopen("in.txt","r",stdin);
	int i,j;
	while(scanf("%d",&n)!=EOF)
	{
		memset(vir,0,sizeof(vir));
		sum=0;
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				scanf("%d",&dis[i][j]);
		minDis(n);
		printf("%d\n",sum);
	}
	return 0;
}

void minDis(int n)
{
	int i,j,temp=n,next=0,min,count=0;
	vir[0]=1;
	while(--temp)
	{
		min=MAX;
		t[count++]=next;             //把新找到的一个最小树的点加入t数组
		for(j=0;j<count;j++)
		{
			for(i=0;i<n;i++)
			{
				if(dis[t[j]][i]<min && !vir[i])
				{
					min=dis[t[j]][i];
					next=i;
				}
			}
		}
		vir[next]=1;        //标记
		sum+=min;
		//printf("%d %d %d\n", min, count ,next);
	}
}



分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics