`

poj 3009 Curling 2.0-----搜索

 
阅读更多

Curling 2.0
Time Limit:1000MS Memory Limit:65536K
Total Submissions:6807 Accepted:2841

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

...
h-th row of the board

The width and the height of the board satisfy: 2 <=w<= 20, 1 <=h<= 20.

Each line consists ofwdecimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1



题目大意: 在冰上的推石头。 0 代表没有障碍物,1代表障碍物,2是起点,3是终点。 玩法,从起点开始,每次可以选择一个方向推出石头,中途不能停,必须撞到障碍物才能停下,同时 障碍物被打碎。求最少需要推几次。 出界算失败,超过十次也算失败。 如果 不能到终点 输出 -1。

思路: 模拟,深搜即可。

这道题很无语。 WA了很久。 后面 初始化一下地图就过了。

但是我没搞懂为什么每次要初始化 地图。 所有的搜索都是建立在地图内搜的。应该不需要每次都初始化地图吧? 求各位大神 解释解释。

还有,这题 我一开始想的是BFS,但是 遇到了 很多问题。地图上的同一个点可能会停多次,如果BFS 不好记录父亲, 暂时不知道怎么做, 各位大神试试 BFS怎么 做这道题吧,求教。


#include<stdio.h>
#include<string.h>
int map[30][30],min,w,h;
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};         //方向
void dfs(int x,int y, int count);
int main()
{
//	freopen("scar.txt","r",stdin);
	int i,j,stx,sty;
	while(scanf("%d%d",&w,&h)!=EOF && w)
	{
		memset(map,0,sizeof(map));        //主要就是这里 , 为什么一定要每次初始化?
		min=15;
		for(i=0;i<h;i++)
			for(j=0;j<w;j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j]== 2)        //找出起点
				{
					map[i][j]=0;
					stx=i;
					sty=j;
				}
			}
		dfs(stx,sty,1);            
		printf("%d\n",min<15 ? min : -1);     //如果min的值未改变 则不能完成游戏.
	}
	return 0;
}
void dfs(int x,int y, int count)
{
	if(count > 10) return;
	for(int i=0;i<4;i++)
	{
		int tx=x+dir[i][0], ty=y+dir[i][1];
		if(map[tx][ty]== 3)          //如果直接能到终点
			if(count < min) min=count;
		while(map[tx][ty]==0 && tx <h && tx>=0 && ty< w && ty>=0)    //选择方向
		{
			tx=tx+dir[i][0];
			ty=ty+dir[i][1];
			if(map[tx][ty]==1)          //撞到障碍物,停下.
			{
				map[tx][ty]=0;          //撞碎障碍物.
				dfs(tx-dir[i][0],ty-dir[i][1],count+1);        //从新的点开始.同时 记下步数.
				map[tx][ty]=1;          //地图复原 .
				break;
			}
			if(map[tx][ty]==3)            //到达终点 
			{
				if(count< min) min=count;
				break;
			}
		}
	}
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics